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Importing

1. Once you have downloaded the asset,
Click on import all.

“rsonal (64bit) - Untitled - Demonstration - PC, Mac & Linux Standalone <DX11> W

GameObject Component Window Help

J:j Import Unity Package

|| AFPC_pck

v o & arrc
v @%Content
v @%Animation
v Q%JumpKickBack
»' HealthDecreaseKickBack.anim L
[ ¥ JumpkKickBack.anim -

v @%Animator
4 D KickBack_cntrlr.contraller
¥ ¥ ESDemoScenes

¥ v 5 MobileScene
@k;LightingData.asset
|l ReflectionProbe-0.exr
[ |l ReflectionProbe-1
[ QMobileScene.unit
[ QStandanneScene.unity
v o @Materials And Textures
v 1P .

=

| Al || none | |Cance||lImpor‘tJ

2. Changing the Graphics Settings,
Reason — Currently, if you build your game then fog
Will not show up in the build when you are
underwater, to fix that,
a.Go to Edit > Project Settings > Graphics
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Q Unity 2017.3.0f2 Perscnal (64bit) - StandaloneScene.unity - Demonstration - PC, Mac & Linux Standa
File Assets  GameObject Component AFPC Window Help

@ Undo Selection Change Ctrl+Z  Elgbal
= Redo Ctrl+¥ | . € Game 28 Animator
Crei Cut ChrleX 2D || o || &
('3 i
I Copy Ctrl+C
i Paste Ctrl+V
|
I Duplicate Ctrl+D
| Delete Shift+Del
f Frame Selected F
Lock View to Selected Shift+F
Find Ctrl+F
Select All Ctrl+A Input
Tags and Layers
Preferences... o
Audio
Modules... )
Tirne
Pla}' Ctrl+P P|a}rer
Pause Ctrl+5Shift+P Physics
Step Ctrl+Alt+P Physics 20
23 P Sign in... Quality
e o ot Graphics
- Metwork
I »
Selection Editor
Project Settings k Script Execution Order
Y& Graphics Emulation 4
[ =Senstivity ySenstivity
Metwork Ermnulation 3

Snap Settings...

= DemoSch
&l Materials .
&3 PhysicsMa
&l Prefabs

e ey vam

v

GraphicsSettings.asset
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€ Unity 2017.3.0f2 Personal {64bit) - StandaloneScene.unity - AFPC - PC, Mac & Linux Standalone
File Assets  GameObject Component AFPC  Window Help

ﬂ Unde Selection Change Ctrl+Z  Elgbal
= Redo Ctrle¥ | | € Game %8 Animator
€=t CtrieX | fllenf]xk [4) @I
<
| Copy Ctrl+C
i Paste Ctrl+V
|
| Duplicate Ctrl+D
' Delete Shift+Del
1
f Frame Selected F
Lock View to Selected Shift+F
Find Ctrl+F
Select Al Ctrl+ A Input
Tags and Layers
Preferences... - =
Audio
Modules... )
Time
Play Ctrl+P Player
Pause Ctrl+5hift+P Physics
Step Ctrl+Alt+P Physics 2D
23 Py Sign in.. Quality |
L S on out Graphics i
) - Metwork
i »
Selection Editor
Project Settings 4 Script BExecution Order
Graphics Emulation
Standalone..

MNetwork Emulation >

Snap Settings...

&5 Water E
&3 PhysicsMa
&3l Prefabs
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T |-

| & collab ~ | @ [ Account ~ | |Layers - [ |Layout - |

-= | @ Inspector | 37 Lighting Services -
- Tags & Layers #*,

3 e I

-

»Tags

» Sorting Layers

¥ Layers
Builtin Layer 0 Default
Builtin Layer 1
Builtin Layer 2
Builtin Layer 3
Builtin Layer 4 Water
Builtin Layer 5 UI
Builtin Layer &
Builtin Layer 7
User Layer 8 |Player

User Layer 9
User Layer 10
User Layer 11
User Layer 12
User Layer 13
User Layer 14
User Layer 15
User Layer 16
User Layer 17
User Layer 18
User Layer 19
User Layer 20
User Layer 21
User Layer 22 \ 3
User Layer 23

User Layer 24

User Layer 25

User Layer 26

User Layer 27 -
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| & collab ~ | | [al | | Account -~ | |Layers - | |Layout - |
| @ Inspector | 5% Lighting Services B =
g ™ [AFPC_ Player Static v -
v Tag | Untagged + | Layer| Player 3 r
Prefab Select | Revert 0: Default
P~  Transform 1: TransparentFx
LalFH Capsule (Mesh Filter) e Igngre Ra}rcagt
v | ¥ capsule Collider & Water
| b | Edit Collider o, I
Is Trigger L] v B Player
Material =£Player
Center ® 0 ¥ Add Layer...
Radius 0.5
Height 2
Direction | ¥-Axis 2]
F % Rigidbody [ %
L4 @ [ AFPC_Player Movement (Script) EI &,

¥ Player Type And States

Player Type: Rigid Body Player #
Player State: Standing_0 +
Player Type is the type of player!
PlayerStates are automatically controlled ingame,
PlayerState refers to the player's current state!

¥ Cursor Lock
Lock Cursar: o
Cursor Lock Mode: Locked %

Disable Cursor LockKey:

Lack Cursar contrals wether the cursor should be
locked or not in game! -
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| Collab - | | ey | | Account -~ | |Layers ~ | |Layout - |
3 Inspector | =% Lighting 2 =
Cursor Lock Mode: Locked + r

Disable Cursor LockKey: m

Lock Curser controels wether the cursor should
be locked ar notin game!

WantedCursarLock is the CursorLockMode
Wanted on pressing left mouse buttan.
DisableCursorLockKey is the key to be pressed N
to disable cursor lack!

¥ Rigidbody Player Movement Settings

Maximum Player Speed: 40

Forward Walk Acceleration 3

Backward Walk Accelerati 2

Strafe Walk Acceleration: 2.5

Player Rigidbody Drag wh| 5

Layer Mask: CEID

Forward Run Acceleration Nothing

Backward Run Acceleratio .
Everything

Default

Strafe Run Acceleration:
Moverment Slope Curve:
Stop Player Immediately | ¥ TransparentFx
Maximum Grounded Anglel Ignore Raycast

Has Air f:f:untrnl: v | Water
Allow Sliding when on stee -
Minimum Slide Angle:

Sliding Acceleration Down Player

Air Acceleration: 5
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1. Creating Player!

To create player->

1.Go to AFPC Window > Create > Player

ene.unity - AFPC - Android <DX110n DX9 GPU>
it | AFPC | Window Help

- Create L Ladder Ctrl+Shift+L
S Soame Tea  Pickupltem Ctrl+ Shift+M
Shaded 7| | Player Ctrl+Shift+ K
B Mew Surface Ctrl+5Shift+5
WaterZone Ctrl+Shift+W

2.Select the Platform of Player You Want -
a.Standalone For Windows, Mac or Linux
b.Mobile For Android, 10S or any other mobile
Platform
3.Select the type of Player
4.Select the footstep Detection Mode -
These are the footstep detection mode
Use Based on Tags if you simply want to change
Footstep sound according to tag of Ground
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Use Based on Textures if you want to change footstep
Sound according to the texture of Ground

REMEMBER -
BASED ON TAGS FOOTSTEPS DETECTION MODE DOES NOT

SUPPORT MULTIPLE FOOTSTEP SOUND ON A TERRAIN
BECAUSE IT DEALS
WITH TAG OF THE GROUND

5.Then, click on Build Player! To create player.

Build Player

Rigid Body Flayer
Standalone

Based On Tags

Build Player!

6.If Player is not on ground then set the appropriate
ground distance and click Place on Ground!
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[ (64bit) - MobileScene.unity - AFPC - Android <DX11 on DX9 GPU

Dbject Component AFPC  Window Help

Ty
5 — =
M= #iScene | € Game 28 Animator
| Shaded =120 ) 6 [ <) | ad | Gizmos | [arAll
—

| | Build Player

Rigid Body Player
Standalone

| :

Build Player!
15

| @ Animation
rror Pause iter *

7.0r you can simply drag and drop the AFPC_Player prefab
along with HUD and EventSystem prefab of the desired
platform.
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2. Creating Ladder

1. Go to AFPC Window > Create > Ladder

2. Select the Ladder You Want to Spawn, its position and
Size.

3. Click on Build Ladder, Ladder Is Ready For Use!

Center | & Global umm i Collab = @
=| #Scene | € Game .=  © Inspector 5= Lighting
||| shaded T 2D || || izmos 7| (o All

m
C.
o
=
o
= |
o
0]
=
Il >

\flLadder
1213 45
I 1346

Build Ladder!

W[/

mat

H consal

» Content » Models

ar
-
Building_02
:

&
or

eeeeee
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3. Creating Pickup Item

1. Go to AFPC Window > Create > Pickup ltem.
2. Select the pickup type, spawn position and the
Gameobject you want to spawn.

3. Click Build Pickup Item! It’s done.

CEm) )
o= '© Inspector | & Lighting
iz L | v @ & PickupBox
-
Tag | Untagged
\f

Build Pickup Ite |
Pickup Tyr Health

Build Pickup Item!

" Center
L=l size X 0.
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4. Creating New Surface

1. ONLY CREATE SURFACE LIKE THIS IF YOU ARE USING BASED
ON TEXTURES Footstep Detection Mode.

2. Go to AFPC Window > Create > New Surface.

3. Type the surface name & Click on Create Surface.

ne_02.unity - - ac & Linux Standalone <DX11

Window Help

slobal

€ Game =

2D || et | o) | BT Gizmas v | (arAll

Build New Surf,

I Console =
o

| | O |

4. Now, Go to AFPC > Content > Surfaces in Project Window.

5. You will find your newly created surface there, just add
Some Footstep sounds and textures and it’s all Done.
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PauseManager
® Inspector |
5 Concrete
i)
Secript AFPC_Surface
Name Concrete
Landing Sound None (Audio Clip) [o]
¥ Surface Foot Step Sounds
Size 0
¥ Texture
Size 0
i Project () Animation 28 Animator El Console
Create ™
E;I;:;:SME‘ 4 Assets » AFPC » Content » Surfaces )
¥ &3 Prefabs

5 Effects

"%Soundg M M M
&5 climb v PEf [V DEf \Tv/DE]

&5 Demos: m Grass Grawvel

T%Footste;
%Defaﬂ
EG"ES |Asset Labels
55 Gravi
& Gasp
&3 Pain AssetBundle Mone

&5 Water
¥ == Concrete.asset

5. Creating Water Zone

1. Go to AFPC Window > Create > Water Zone.

2. Select the water plane you have to spawn, spawn position
& if you want to automatically calculate the water zone size,
Set auto calculate size to true else give the size of water

Zzone.
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& Linux Standalone* <DX11>

(> [ 11 [ ] [ & ] [Account

® Inspector == Lighting

o All

Gizmos ~

[ |Water
Tag | Untagged

Build Water Zone!

Script
Speed X 0.05
Speed ¥ 0.025

Water Base
- Shader | Standard

Add Com

Madels PhysicsMa.. Prefabs Sounds Surfaces
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6. Creating Platform

1. Go to AFPC Window > Create > Platform.

2. Select the platform you have to spawn, spawn position
& set the platform size to the transform’s Scale of your
platform model/prefab.

Create Platforn | .

Platform Size is the Lecal Scale of the Platform
Prefab

Create Platfarm!
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Using Custom Player Body
1. Importing Body

1. Import Player body and set the Rig mode to Humanoid
and create an avatar.

I & Collab ~ J [ &y ] IAccount - ] [Layers - J [Layout -

© Inspector o= Lighting B Ccclusion =
t Malcolm Import Settings @ %
Cp

Animation Type | Humanoid 2
&y atar Definition | Create From This Madel 3|

+ | Configure.. |
Optimize Game Objects -

Revert || Apply

2. Insert player body in you scene.
3. Select it and add Animator Component to it and set the
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AFPC_Legs

Collab - | @ | Account - | | Layers - | |Layout - |

| @ Inspector | 3% Lighting I Ccclusion .=

J o Legs_Malcalm Static ¥

%
Tag Untagged i | Layer | Legs *

Prefab Select Rewvert Apply

~ Transform @

Position ¥ 0 -1 Z -0.23

Rotation ® 0 |0 Z0

Scale X 0.5084127 ¥ 0.5064126 Z 0.5064126

it & Animator G #

Caontroller EFPS_Legs (]

Avatar & Malcolmavatar @

Apply Root Motion L

Update Mode | Marmal ™

Culling Mode | Always Animate % |

Clip Count: 24
i Curves Pos: O Quat: O Euler: 0 Scale: 0 Muscles: 4420 Generic: 0 PPt O
Curves Count: 4420 Constant: 493 (11,2%) Dense: 168 (3.8%) Stream: 2759 (85.0%)
| ¥ AFPC_Legs (Script) @ #

Add Component
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|@|$|$|:I:I: l'iPivutlﬁLucalJ

“= Hierarchy | = Hscene | € Game
Create 7| (orall Shaded (2D || w0 | <) | T Gizmos ~
hd QBasi:E:ene =
b Level
b AFPC_MinimapGamelbject

LegsCamera
b Legs_Malcolm

b AFPC_Player

b HUD_STAMNDALOME
EventSysterm_STANDALONE
PauseManager

P Door_Key

= Door

5. Change the Layer of the model’s Gameobject to Legs.

2. Setting up Legs Camera

1. The LegsCamera Gameobject renders legs above all other
layers so that legs should always be visible in game.

2. In case of water, it has to be rendered with the same depth
as of legs to see it above legs else legs will not look immersed
in water.

3. Just like water, if you want any Gameobject to render above
Legs, Create a new layer, in this scenario, let’s say the Layer
Name is “Water”.

4. Now, select your water Gameobject and set its layer
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| & collab - | | [alk | | Account - | | Layers - | |Layout -
| & Inspector | 3% Lighting B, Occlusion =
Occlusion Culling -
Allow HDR +
Allow MSAA
(G AFPC_Under Water Blur Effect (Script) D ,
Script AFPC_UnderWaterBlurEffect
Blur Material @ UnderWaterMaterial o]
Iterations - 5
Down Res & 1
G AFPC_Under Water Displace Effect (Script) D i,
Script AFPC_UnderWaterDisplaceEffect o]
Effect Material @ UnderwaterDisplace o]
G| [« AFPC_Player Follow (Script) g #%.
Script AFFC_FlayerFollow o .
Unfallow Flayer On Death
Follow All Axis +
Follow X Axis
Follow ¥ Axis
Follow Z Axis ]
Follow Rot All Axis T
Follow Rot X Axis Everything
Follow Ret Y Axis v Default
Follow Rot 2 Axis v TransparentFx _
Offset Z0
¥ Ignore Raycast £
Target m) @
i} F
Time To Reach Target Pasition Water
Time To Reach Target Rotation v Ul
| ¥ AFPC_Legs Cam (Script) v Player @ =,
Script Minimap L
Culling Mask s L #
Legs Layer ) L ]
Player Camera Culling Mask v | Temain | 0
Add Component

4
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Creating Door
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| @ Inspector | 35 Lighting

Position

Rotation

Scale

vt ¥ Animator
Controller

Avatar

Apply Root Motion

Update Mode
Culling Mode

Clip Count: 2

AFPCY

Collab - | | [alk | | Account - | |Layers - | |Layout ~
B Occlusion - =
®|3.52 T11 Z|4.34 4
®|0 |0 Z|0
w03 ¥ |0.3 £0.3
@ =
Ty
fDoor_DemoZ o
MNone [Avatar) @

Root position ar rotation are contralled by curves

Marmal

Always Animate

1 Curves Pos: O Quat: 0 Euler: 3 Scale: 0 Muscles: O Generic: 0 PPtr: O
/' Curves Count: 9 Constant: 3 (33.3%) Dense: 0 (0.0%) Stream: 6 (66.7%)

J ¥ Box Collider

Is Trigger

Material

Center

Size

# |« AFPC_Door (Script)
Script

Door Animator

Door Open Sound

Door Close Sound

Key Pickup Sound

| £ | Edit Collider

ar

Mone (Physic Material) @
K| -2.28 Y0 Z 0
w 4,08 704 Z 0.3
W
AFPC_Door o]
$2 Door (Animator) ]
WoodenDoor_Open ]
WoodenDoor_Close ]
422709 __niamhd00145229_ inspect-itern ]

Audio Volume 0.73
Door Opened Initialy

Require Key o
Animator Open Door Param Mame DoorQpen

Add Component
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Understanding Scripts

CO nta Ct US = https://gamedevtips9854.wixsite.com/hyperbolt

Hyper



